I’m Finally on 2.2!

Over the weekend, I received a couple of emails from my hosting provider that my blogs were outdated because I was still on WordPress 2.1.3. So today, I decided to stop these periodic emails coming in to my mailbox and upgraded my blogs to WordPress 2.2. I had previously installed my WordPress using the easy-to-use cPanel Fantastico Deluxe installation, which required just a mere click of a button. And upgrading to WordPress 2.2 was equally simple. First I exported my entire blog into XML format for backup purposes (Manage > Export > Save XML file to local hard disk) and then I just clicked on the Upgrade link in my cPanel. Easy-peasy!

Or so I thought… this afternoon I received feedback from 2 of my colleagues (who also read my blogs) that my blogs had a weird A character appearing after every sentence in every post! I did a quick check and sure enough, it was like a slew of ASCII codes had attacked me blogs! Aaarrrrghhhhh!!!! I sent a quick email to my hosting provider and within an hour, I received a reply from them. Apparently, I had to comment out 2 lines of code in the wp-config.php file. According to the helpdesk, this is because WordPress 2.2 by default does not establish proper UTF-8 connection to the database, especially when the upgrade is done using Fantastico. So there was the problem. 🙂

So for those of you who also face this similar problem, here’s the fix. Just comment out the following 2 lines of code in your wp-config.php file, which is located at /home/<login name>/public_html/wp-config.php :

define(‘DB_CHARSET’, ‘utf8’);
define(‘DB_COLLATE’, ”);

After commenting, it should look like this (with the pound/hash (#) symbol in front of each of the lines:

#define(‘DB_CHARSET’, ‘utf8’);
#define(‘DB_COLLATE’, ”);

So much for all that technical hooha. I’m back…and 2.2 is up and running!

This entry was posted in Thoughts & Scribblings. Bookmark the permalink.

20 Responses to I’m Finally on 2.2!

  1. ParisB says:

    Gosh m’dear you had me at 2.1.3. I’m so bad with upgrading wordpress, I think i’ll wait it out a bit more. The last time I tried upgrading it nearly killed me and my blog! Yes, i have a small brain when it comes to things like this 🙂

    The Giddy Tiger says: Good thing my upgrade was made possible with a click on a link. I don’t think I would have wanted to try it any other way. You’re still on 2.1.3?

  2. chinnee says:

    i am still in 2.1.3. which host company are u attached with? I have heard about this Fantastico in cpanel, but i can’t see it in my cpanel..am very blur with this whole thing. After so many failures installing WP 2.1.3 myself, i finally got the WP support to do it for me. Now pulak about 2.2. is it recomended to install it?

    The Giddy Tiger says: My site is hosted with Exabytes. And installation with Fantastico is really idiot-proof – just the way I like it. Well, higher versions are supposed to be better in terms of performance, yadayadayada….

  3. rinnah says:

    So that was why I saw the A symbol too! I figured something was wrong with my RSS feeder. Heh.

    The Giddy Tiger says: I funny thing was everyone thought something was wrong with their reader, browser, etc…nobody reported that to me till the afternoon! 😛

  4. Leah says:

    I just moved fr blogger to wordpress, was able to use cPanel Fantastico to install 2.2. Don’t know whether will have the same problem or not… ?

    The Giddy Tiger says: Lucky you! If you move directly to 2.2, I don’t think you will have that problem. But in the event you do, you can always refer to my post on how to solve it, yes?

  5. LB says:

    I noticed the funky character too, but thought it must have been some Windows thing!! LOL… Also, I just upgraded mine from 2.1 to 2.2.1 last Saturday! Not for the faint of heart.. but it went seamlessly, as far as I can tell..

    The Giddy Tiger says: 2.2.1?? Wah…ahead of the pack already, I see… hehehe..

  6. Pink Cotton says:

    woohoo….
    eh can ask u ah…u host ur blog on wordpress isit?i don understand how all this works 😛

    The Giddy Tiger says: Yeppers… my blog is hosted on wordpress. When I got my own domain, I installed WordPress. Well, you can also use the FREE WordPress blogs from WordPress.com but the one I have is from WordPress.org

  7. pelf says:

    Hahhaha, two of my other blogs are also using WP 2.1.3.
    Dang. I think I need all the help tp upgrade them because my current blog was upgraded to WP 2.2 by Edrei..

    The Giddy Tiger says: Hope my post’s tips will come in handy!

  8. Gallivanter says:

    Yeah, I faced the same problem with those funky characters too, will do this at home later, thanks. 🙂

    The Giddy Tiger says: No problem. All the best!

  9. wuching says:

    i dun even know what mine is!

    The Giddy Tiger says: If it is working fine, no need to touch it! 🙂

  10. Neo says:

    Do I need to upgrade? So lazy ler…

    The Giddy Tiger says: It’s not compulsory but I heard that 2.2 is more stable.

  11. pelf says:

    Actually.. No.. I need more detailed instructions than “export the entire blog into XML format for backup purposes (Manage > Export > Save XML file to local hard disk) and then click on the Upgrade link in cPanel.”

    Arghh…

    The Giddy Tiger says: 🙂 Okay, let me rephrase that 🙂 In WordPress itself, there are several menus at the top: Dashboard, Write, Manage, Comments, etc. Click on Manage and then choose the Export option. This will by default export your blog (posts & comments) to XML format which you can choose to save to a location on your PC. (by the way, this is the method I use to backup my blog too)
    Now, if your hosting provider has cPanel, then you can login to cPanel and check if they have Fantastico Deluxe installed. It should be somewhere at the bottom if it’s there. After you click on Fantastico, it will list down all your WordPress installations and if the one-click-upgrade option is available, you can just click on it. Hope this clarifies. If not, please feel free to drop me an email. 😀

  12. michelle says:

    I still like the 1.5.2…:P Why change when it is not broken. 😛

    The Giddy Tiger says: Wah….even more dinosaur…just kidding! 🙂

  13. Chen says:

    I tot wat was that 2.2 u r talking about when I read the title of your post 😛

    The Giddy Tiger says: That’s one of my ploys to attract readers and get them reading! *wink* Glad it worked!

  14. cc says:

    After a long consideration, I am finally taking the plunge and getting on the WordPress bandwagon. Still waiting for the domain to be transferred to my new host. Hope everything will go without a hitch. 🙂

    The Giddy Tiger says: Good move! Which hosting provider did you sign up with?

  15. cc says:

    I’m with Exabytes.

    The Giddy Tiger says: Then it should not be a problem installing WP2.2. Just click the link 🙂

  16. may says:

    and I’m still stuck on 2.0, LOL! procrastinate, procrastinate…

    The Giddy Tiger says: Should be all right, because I see nothing wrong with your site!

  17. Ouch. Keeping up with this would make my head hurt. 0_o

    So glad I use Yahoo. They do all of that stuff for me.

    The Giddy Tiger says: They do?? So you’re on 2.2 already?

  18. Pingback: little miss may » upgrades on a sunny day

  19. *blush*

    I onli on 2.02. Must nag Yahoo!

    The Giddy Tiger says: I just received a notification to ask me to upgrade to 2.2.1

  20. ParisB says:

    Kamsiah for your tips. I got upgraded and managed to correct that weird character in no time at all, thanks to your helpful post! 😀

    The Giddy Tiger says: No problemo… by the way, I’m being prompted to install 2.2.1 already now. Gathering the guts to do it first.

Leave a Reply to wuching Cancel reply

Your email address will not be published. Required fields are marked *